Outage
Incident Report for SatisMeter
Resolved
The application is back online and stable. There were no impacts to your surveys, in any way or shape. Our team will continue to monitor it closely. Thank you for your understanding.
Posted Aug 19, 2021 - 17:18 UTC
Investigating
Our application is currently down. The technical team is investigating the issue. Our apologies for any inconveniences caused. We will keep you informed of our progress.
Posted Aug 19, 2021 - 15:35 UTC