[E-mail Invitations not working!]
Incident Report for SatisMeter
Resolved
E-mails invitations are now being sent as normal. Our team will continue to monitor the sending. If you notice any issues, please report to Support.
Posted Jul 22, 2021 - 17:45 UTC
Investigating
Our e-mail invitations are currently not being sent. We are working on bringing them back.
Kindly use the joining link to invite your team members!
More information to follow.
Posted Jul 22, 2021 - 08:15 UTC