E-mail services not working
Incident Report for SatisMeter
Resolved
This is incident has been resolved. All e-mail services are working to all accounts, including Trials. If you notice anything odd, please contact Support. Thank you for your patience.
Posted Aug 07, 2021 - 06:51 UTC
Update
[Update] Emails services for all paying customers are restored. Trials accounts still do not receive invitation and reset password emails. Please, contact Support if you require assistance with these services.
Posted Jul 24, 2021 - 20:19 UTC
Investigating
Email invitations, email digest, and other service emails are currently on hold. Email surveys are NOT affected, as their distribution is not done by SatisMeter, but your e-mail providers. We are investigating the issue.
Posted Jul 23, 2021 - 20:16 UTC