Satismeter Latency
Incident Report for SatisMeter
Resolved
This incident has been resolved.
Posted Mar 15, 2023 - 17:14 UTC
Investigating
SatisMeter is currently experiencing increased latency that is causing delays when loading internal dashboards. Surveys are still delivered to recipients and data is still collected, but delays are expected. We are currently investigating the issue and will provide further updates when more information is available.
Posted Mar 15, 2023 - 16:42 UTC
This incident affected: SatisMeter Web Application and SatisMeter Surveys.